RUNRMTCMD

vos questions et suggestions sur ce forum, et son fonctionnement
Répondre
c_volubis
Messages : 4
Enregistré le : mar. 21 avr. 2020, 10:11:37

RUNRMTCMD

Message par c_volubis »

Bonjour,

Je dois remplacer dans mes CL la commande RUNRMTCMD par un nouveau process SSH mais je rencontre des problèmes, Auriez-vous la gentillesse de bien vouloir m'aider si vous avez déjà effectué cela.

Ce que j'ai fait :

Sur mon PC j'ai activé le client OPEN SSH

Sur mon AS400

STRTCPSVR *SSHD
CALL QP2TERM
ssh-keygen -t rsa -f ssh_host_key -N ""
ssh 'IP ADRESS' achisdr ‘ls' ‘-l’

Le rendu de cette commande est vide

Merci d'avance

cmasse
Site Admin
Messages : 757
Enregistré le : mer. 14 févr. 2007, 18:00:03
Localisation : Nantes
Contact :

Re: RUNRMTCMD

Message par cmasse »

Je suis perplexe, c'est censé produire quoi comme résultat
(connais pas cette syntaxe il semble que Google non plus) ?

votre IBMi/AS400 est le client ou le serveur ?
Christian Massé (Volubis.fr)

c_volubis
Messages : 4
Enregistré le : mar. 21 avr. 2020, 10:11:37

Re: RUNRMTCMD

Message par c_volubis »

Merci pour le retour, Le résultat devrait être une connexion user et mot de passe, j'ai configurer le fichier sur AS400 dans IFS chemin ci-dessous : et idem sur mon PC chemin ci-dessous mais je n'arrive pas à me connecter, et je ne comprend pas ce que je fais de faux.

AS400 - ‎IFS
/QOpenSys/QIBM/UserData/SC1/OpenSSH/etc‎/‎sshd_config‎

Port 22
# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication yes

PC - C:\Windows\System32\OpenSSH\sshd_config
C:\Windows\System32\OpenSSH/sshd_config_default

Merci d'avance

cmasse
Site Admin
Messages : 757
Enregistré le : mer. 14 févr. 2007, 18:00:03
Localisation : Nantes
Contact :

Re: RUNRMTCMD

Message par cmasse »

JE renouvelle ma question, vous voulez faire dans le sens PC vers IBM i/AS400 ?

le serveur SSH est bien démarré (STRTCPSVR *SSHD) ? vous le voyez dans NETSTAT *CNN ?
Christian Massé (Volubis.fr)

c_volubis
Messages : 4
Enregistré le : mar. 21 avr. 2020, 10:11:37

Re: RUNRMTCMD

Message par c_volubis »

AS400 vers PC, le protocole SSH est démarré.

ssh 073:20:18 Listen

cmasse
Site Admin
Messages : 757
Enregistré le : mer. 14 févr. 2007, 18:00:03
Localisation : Nantes
Contact :

Re: RUNRMTCMD

Message par cmasse »

Alors la config sshd_config‎ et le démarrage par STRTCPSVR *SSHD importent peu


Voyez ce document pour la config SSHD sur un serveur windows (2016 ou +)

https://www.ibm.com/support/pages/node/888107
Christian Massé (Volubis.fr)

c_volubis
Messages : 4
Enregistré le : mar. 21 avr. 2020, 10:11:37

Re: RUNRMTCMD

Message par c_volubis »

Merci, selon le document du lien, j'ai effectué les étapes précédentes, mais arrivé à cette commande ci dessous, j'ai eu cette erreur :

PS C:\WINDOWS\system32> Install-Module -Force OpenSSHUtils -Scope AllUsers
PackageManagement\Install-Package : The module 'OpenSSHUtils' cannot be installed or updated because the authenticode signature of the file 'OpenSSHUtils.psd1' is not valid.
At C:\Program Files\WindowsPowerShell\Modules\PowerShellGet\1.0.0.1\PSModule.psm1:1809 char:21
+ ... $null = PackageManagement\Install-Package @PSBoundParameters
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (Microsoft.Power....InstallPackage:InstallPackage) [Install-Package], Exception
+ FullyQualifiedErrorId : InvalidAuthenticodeSignature,ValidateAndGet-AuthenticodeSignature,Microsoft.PowerShell.PackageManagement.Cmdlets.InstallPackage

Merci d'avance

cmasse
Site Admin
Messages : 757
Enregistré le : mer. 14 févr. 2007, 18:00:03
Localisation : Nantes
Contact :

Re: RUNRMTCMD

Message par cmasse »

Aïe, du coup il faudrait des compétences Microsoft, ce qui n'est plus ma spécialité.

voyons si d'autres membres sont plus au fait ....
Christian Massé (Volubis.fr)

Répondre