migration v5r4 en v6r1

vos questions et suggestions sur ce forum, et son fonctionnement
Répondre
meggiolaro
Messages : 25
Enregistré le : mar. 30 nov. 2010, 14:17:06

migration v5r4 en v6r1

Message par meggiolaro »

bonjour,
je dois migrer les données d'un système 9406/520 en v5r4 sur un système 8282-E4B /P7 en v6r1
le client aura fait une sauvegarde complète ( option 21) de l'ancien système
quelle commande je dois utiliser pour la restauration des bibliothèques dossiers et objet IFS a partir de cette sauvegarde?
comment restaurer si le clienta des objets dans qsys ou qusrsys de l'ancienne machine vers la nouvelle?

pmaugin
Site Admin
Messages : 30
Enregistré le : mer. 14 févr. 2007, 18:28:48

(sans texte)

Message par pmaugin »

Il faut utiliser l'option 23 du menu RESTORE.
Voir la signification des options 21,22 et 23 par F1 sur l'option.
Idem pour le menu SAVE.

(faire faire un changement de machine et/ou de version par quelqu'un qui n'a pas ou plus de compétence dans le monde AS400 n'est pas sans risque ...)
Philippe MAUGIN, (RAUTUREAU APPLE SHOES)
V7R2.

cmasse
Site Admin
Messages : 764
Enregistré le : mer. 14 févr. 2007, 18:00:03
Localisation : Nantes
Contact :

migration

Message par cmasse »

Voir la réponse de Fabrice dans le POST suivant

http://www.volubis.fr/forum/viewtopic.php?t=170

et plus généralement la documentation


http://publib.boulder.ibm.com/infocente ... rzahc1.htm
Christian Massé (Volubis.fr)

meggiolaro
Messages : 25
Enregistré le : mar. 30 nov. 2010, 14:17:06

(sans texte)

Message par meggiolaro »

vous me confirmer qu'avec l'option 23 de go restaure les bib qsys et qusrsys
de l'ancien systeme ne seront pas restaurer

cmasse
Site Admin
Messages : 764
Enregistré le : mer. 14 févr. 2007, 18:00:03
Localisation : Nantes
Contact :

restore / 23

Message par cmasse »

la réponse est dans l'aide

Code : Tout sélectionner

 *ALLUSR                                                               
     Toutes les bibliothèques utilisateur sont restaurées. Toutes les 
 bibliothèques dont le nom ne commence pas par la lettre Q sont     
 restaurées, à l'exception de :                                     
                                                                    
     £CGULIB     £DSULIB     £SEULIB                                
     £COBLIB     £RPGLIB                                            
     £DFULIB     £SDALIB                                            
                                                                    
 Bien que les bibliothèques Qxxx suivantes soient fournies par IBM, 
 elles contiennent généralement des données utilisateur qui sont    
 fréquemment modifiées.  Ces bibliothèques sont donc considérées    
 comme des "bibliothèques utilisateur" et sont elles aussi          
 restaurées.                                                        
                                                                    
     QDSNX       QRCLxxxxx   QUSRDIRDB   QUSRVI                     
     QGPL        QSRVAGT     QUSRIJS     QUSRVxRxMx                  
     QGPL38      QSYS2       QUSRINFSKR                        
     QMGTC       QSYS2xxxxx  QUSRNOTES                         
     QMGTC2      QS36F       QUSROND                           
     QMPGDATA    QUSER38     QUSRPOSGS                         
     QMQMDATA    QUSRADSM    QUSRPOSSA                         
     QMQMPROC    QUSRBRM     QUSRPYMSVR                        
     QPFRDATA    QUSRDIRCF   QUSRRDARS                         
     QRCL        QUSRDIRCL   QUSRSYS                           
Christian Massé (Volubis.fr)

meggiolaro
Messages : 25
Enregistré le : mar. 30 nov. 2010, 14:17:06

(sans texte)

Message par meggiolaro »

ce qui veut dire que ses bib systeme ( qsys qusrsys)avec des objets clients vont redescendre en version v5r4 et je ne veut pas

Benjamin
Messages : 3
Enregistré le : ven. 05 août 2011, 15:51:31
Localisation : Deux-Sèvres

(sans texte)

Message par Benjamin »

Bonjour,
L'entreprise pour laquelle je travaille doit changer de version pour passer de la V5R4 en version 6.1 ou 7.1. Je suis sous AS/400 depuis peu.
J'ai trouvé des infos sur les nouveauté des versions 6.1 et 7.1 mais il y a toujours une question qui est présente :
Le RPG-III est-il toujours utilisé?
Si oui, y a t-il des particularités?
Car je n'est rien trouvé qui me le confirme

Si quelqu'un peut me renseigner à ce sujet :)

Fabrice
Messages : 91
Enregistré le : lun. 09 févr. 2009, 09:19:42

(sans texte)

Message par Fabrice »

Benjamin a écrit :Bonjour,
L'entreprise pour laquelle je travaille doit changer de version pour passer de la V5R4 en version 6.1 ou 7.1. Je suis sous AS/400 depuis peu.
Bonjour,

Petite précision, tu n'es pas sous AS/400 si tu es en V5R4 et que tu comptes passer en 6.1 ou 7.1 car les AS/400 ne supportent que la V5R3 au maximum ;)
Ton serveur est plus probablement en System i5 ou Power Systems.
Benjamin a écrit : J'ai trouvé des infos sur les nouveauté des versions 6.1 et 7.1 mais il y a toujours une question qui est présente :
Le RPG-III est-il toujours utilisé?
Si oui, y a t-il des particularités?
Le compilateur RPGIII (OPM) est toujours supporté en V6R1 et V7R1, la principale particularité à partir de la V6R1, est que le produit de développement WDS (WebSphere Development Tools) est décomposé en 3 entités :
- Heritage (contenant les compilateurs OPM)
- ILE (contenant les compilateurs ILE)
- ADTS (contenant les outils de développement comme SEU, PDM, SDA ...)

Chaque entité est facturée à l'utilisateur (développeur), attention donc à disposer des modules nécessaires à tes besoins et surtout de disposer du nombre de licences qui va bien.

Autre particularité, depuis la V7R1, l'outil de développement SEU (contrôle de syntaxe) ne supporte plus les nouvelles focntionnalités du RPG, COBOL et C/C++, mais cela n'a aucune incidence sur les outils OPM (RPGIII par exemple) car ces derniers n'évoluent plus depuis des années.

Fabrice

Benjamin
Messages : 3
Enregistré le : ven. 05 août 2011, 15:51:31
Localisation : Deux-Sèvres

(sans texte)

Message par Benjamin »

Fabrice a écrit : Bonjour,

Petite précision, tu n'es pas sous AS/400 si tu es en V5R4 et que tu comptes passer en 6.1 ou 7.1 car les AS/400 ne supportent que la V5R3 au maximum ;)
Ton serveur est plus probablement en System i5 ou Power Systems.
Bonjour Fabrice,
Effectivement, c'est bien un i5, l'habitude d'utiliser le terme AS/400 :D

En tout cas, merci pour toutes ces informations, cela m'aide beaucoup.

Répondre