installWebService.sh

configuration Apache, Zend et PHP , Web services
Répondre
PBL
Messages : 7
Enregistré le : ven. 22 nov. 2019, 15:20:16

installWebService.sh

Message par PBL »

Bonjour,

J'essaie de créer un webservice via la commande shell installWebService.
Cela fonctionne sauf qu'un des paramètres créé me paraît incorrect (en redéployant manuellement, IWS m'oblige à compléter ce paramètre).
Ce paramètre est "Allowed input media types" créé avec la valeur "*ALL".
Et j'aimerais le créer avec *JSON.
Je n'ai pas trouvé la propriété pour agir sur celui-ci.

Voici ma commande dans un CL :
QSH CMD('/qibm/proddata/os/webservices/V1/server/bin/installWebService.sh -server +
WSTEST -programObject /QSYS.LIB/PBLTRAV.LIB/APLTEST2G.PGM -service APLTEST2G +
-userid XXXXXX -detectFieldLengths -serviceType *REST -propertiesFile +
/HOME/PBL/APLTEST2G.properties -libraryList PBLTRAV -libraryListPosition *LAST +
-printErrorDetails')

Et le fichier de propriété APLTEST2G.properties :
uri.path.template=/
APLTEST2G.uri.path.template=
APLTEST2G.wrap.input.parameters=false
APLTEST2G.wrap.output.parameter=false
APLTEST2G.http.request.method=POST
APLTEST2G.consumes=*/*
APLTEST2G.produces=application/json
APLTEST2G.response.code.parameter=
APLTEST2G.http.headers.parameter=
APLTEST2G.PENTREE.usage=input
APLTEST2G.PRETOUR.usage=output

Merci de votre aide.

cmasse
Site Admin
Messages : 794
Enregistré le : mer. 14 févr. 2007, 18:00:03
Localisation : Nantes
Contact :

Re: installWebService.sh

Message par cmasse »

APLTEST2G.consumes=application/json
Christian Massé (Volubis.fr)

PBL
Messages : 7
Enregistré le : ven. 22 nov. 2019, 15:20:16

Re: installWebService.sh

Message par PBL »

Ca fonctionne,

merci.

Répondre