Problème de démarrage du serveur apache de Zend

configuration Apache, Zend et PHP , Web services
Répondre
Gregory
Messages : 18
Enregistré le : ven. 02 juil. 2010, 13:05:44
Localisation : Midi-Pyrénées

Problème de démarrage du serveur apache de Zend

Message par Gregory »

Depuis quelques temps j'ai dans mes fichiers spoules l'erreur suivante qui remonte : "httpd (no pid file) not running".
Par ailleurs, je dois arrêter le sous-système Zend et le redémarrer tous les matins, malgré une procédure ajoutée dans le QSTRUP, afin que le serveur apache réponde (l'arrêt et le redémarrage du serveur apache seul ne suffit pas).
Est-ce qu'il s'agit seulement d'un paramètre à modifier dans le fichier de configuration apache ?
Je ne parviens pas à identifier ce qui génère ces deux problèmes.....
Merci par avance pour vos lumières.
Gregory

cmasse
Site Admin
Messages : 802
Enregistré le : mer. 14 févr. 2007, 18:00:03
Localisation : Nantes
Contact :

Zend

Message par cmasse »

je pense que les deux problèmes sont liés.

mais avant tout de quel Zend parle-t-on, ZENDCORE ou ZEND Server ?

pour Zend Core, le démarrage est inscrit en travail à démarrage automatique dans QSYSWRK

travail --------- Jobd ---------- bibliothèque
ZC_STR_SBS ZCOREJOBDX ZENDCORE

pour Zend Server
ZS_STR_SBS ZSVRIPLD ZENDSVR

Que ce passe-t-il la nuit qui pourrait bloquer tout cela ? un arrêt de sous système ? un IPL ? ,si oui, le profil qui lance QSTRUP a-t-il les droits pour démarrer Zend ?

de toutes façons le démarrage d'apache ne suffit pas, il faut aussi que le sous système Zend (avec les travaux ZENDCOREAP) soit actif.
Christian Massé (Volubis.fr)

Gregory
Messages : 18
Enregistré le : ven. 02 juil. 2010, 13:05:44
Localisation : Midi-Pyrénées

Zendcore

Message par Gregory »

Nous avons Zendcore installé sur une V6R1M0.

Je vais creuser du côté des droits (c'est l'utilisateur QSYS qui redémarre le sous-système Zend).
Gregory

Pascal
Messages : 6
Enregistré le : mar. 05 oct. 2010, 13:29:17
Localisation : France

(sans texte)

Message par Pascal »

Bonjour,

Pour info, j'ai le même message quand je démarre Zendcore avec la commande STRSBS SBSD(ZENDCORE/ZEND) avec un nom de job "ZC_STOP_AP" quand le serveur était arrêté. Je n'ai aucune log quand je fais la même commande et que le seveur était déjà démarré.
Je ne pense donc pas qu'il s'agisse d'un problème.
Par contre, j'avais eu des trucs bizards avec le démarrage de TCP/IP et le sous système ZENDCORE; le sous système démarrait trop tôt par rapport à TCP/IP.

Par sécurité, tous les jours je scédule un redémarrage du serveur après les sauvegardes et IPL.

Pascal

Gregory
Messages : 18
Enregistré le : ven. 02 juil. 2010, 13:05:44
Localisation : Midi-Pyrénées

Zendcore

Message par Gregory »

Bonjour,

Il est fort probable que le démarrage automatique de Zend se fasse avant que les services TCP/IP ne soient démarrés. Je retire donc le sous-système Zend des travaux à démarrage automatique :
RMVAJE SBSD(QSYSWRK) JOB(ZC_STR_SBS).

Je ferai un retour sur les manipulations suivantes en fin de semaine en fonction des résultats (modification dans QSTRUP, suspenssion du job ZC_STR_PRN, ...)

Merci.
Gregory

Gregory
Messages : 18
Enregistré le : ven. 02 juil. 2010, 13:05:44
Localisation : Midi-Pyrénées

Démarrage de Zend

Message par Gregory »

Après plusieurs tests et des modifications apportées dans le QSTRUP pour démarrer les serveurs TCP (s'ils ne le sont pas déjà), c'est un véritable échec.

Je suis toujours obligé d'arrêter le SBS ZEND et de le redémarrer (à partir de l'option 5 du menu ZEND/ZENDCORE) pour que les sites en production soient accéssibles.

Par ailleurs, je dois aussi maintenant démarrer manuellement le serveur netbios si je souhaite accéder à l'ifs depuis un pc (commande STRTCPSVR *NETSVR)

Je ne trouve pas de solution. Même côté support Zendcore, je ne déniche pas plus d'information que ceci : http://www.zend.com/support/knowledgeba ... iew_only=1
Gregory

Pascal
Messages : 6
Enregistré le : mar. 05 oct. 2010, 13:29:17
Localisation : France

Démarrage de Zend

Message par Pascal »

Bonjour,

Essaye de schéduler le pgm ci-après après ton IPL quand tout est bien redémarré. Ce pgm arrête et redémarre le serveur HTTP. Il fonctionne pour le Zend Core for i5, pas testé pour le Zend Server.

PGM
ADDLIBLE LIB(ZENDCORE)
MONMSG MSGID(CPF0000)
CALL PGM(ZENDCORE/ZCCSBSE001)
MONMSG MSGID(CPF0000)
RMVLIBLE LIB(ZENDCORE)
MONMSG MSGID(CPF0000)
SNDUSRMSG MSG('Arret du serveur HTTP ZEND.') +
MSGTYPE(*INFO) TOMSGQ(*SYSOPR)
DLYJOB DLY(10)
MONMSG MSGID(CPF0000)

STRSBS SBSD(ZENDCORE/ZEND)
MONMSG MSGID(CPF0000)
SNDUSRMSG MSG('redemarrage du serveur HTTP ZEND.') +
MSGTYPE(*INFO) TOMSGQ(*SYSOPR)
ENDPGM



Pour ton netserver dans iseries navigator il est bien : "Démarrer en même temps que TCP/IP :Oui "



Pascal

Gregory
Messages : 18
Enregistré le : ven. 02 juil. 2010, 13:05:44
Localisation : Midi-Pyrénées

(sans texte)

Message par Gregory »

Merci,

J'ai donc testé le programme, schedulé suite à l'IPL, mais mon problème persiste (pour rappel, il s'agit d'un environnement Zendcore).

Je vais essayer une autre solution, trouvée sur le forum de Zend. Je remplace donc les lignes de code par :

PGM
ADDLIBLE LIB(ZENDCORE)
MONMSG MSGID(CPF0000)
DLYJOB DLY(300)
CALL PGM(ZENDCORE/ZCCAPCE001)
MONMSG MSGID(CPF0000)
DLYJOB DLY(300)
CALL PGM(ZENDCORE/ZCCAPCS001)
MONMSG MSGID(CPF0000)
ENDPGM

Et je conserve la solution de schéduler l'appel du programme.

Suite au prochain IPL...
Gregory

Gregory
Messages : 18
Enregistré le : ven. 02 juil. 2010, 13:05:44
Localisation : Midi-Pyrénées

Zendcore sur V6R1M0

Message par Gregory »

Suite et fin du périple pour le démarrage du serveur Apache de Zendcore. Voici donc le code final qui nous permet d'avoir tous les services Zend démarrés correctement.... (merci Pascal pour le bout de code) :

Code : Tout sélectionner

    ADDLIBLE   LIB(ZENDCORE)
             MONMSG     MSGID(CPF0000)
 /*      arrêt sous-système zend */
             CALL       PGM(ZENDCORE/ZCCSBSE001)
             MONMSG     MSGID(CPF0000)
             RMVLIBLE   LIB(ZENDCORE)
             MONMSG     MSGID(CPF0000)
             DLYJOB     DLY(300)
             MONMSG     MSGID(CPF0000)
 /*      redémarrage sous-système zend */
             STRSBS     SBSD(ZENDCORE/ZEND)
             MONMSG     MSGID(CPF0000)
             DLYJOB     DLY(300)                       
             QSYS/STRSBS SBSD(ZMYSQL/ZMYSQL)     
             DLYJOB     DLY(20)
             CALL       ZMYSQL/ZMYSQLSTRT
             MONMSG     MSGID(CPF0000)
             DLYJOB     DLY(60)
             CALL       PGM(ZENDCORE/ZCCAPCE001)
             MONMSG     MSGID(CPF0000)
             DLYJOB     DLY(60)
             CALL       PGM(ZENDCORE/ZCCAPCS001)
             MONMSG     MSGID(CPF0000)
Gregory

Répondre