MySql et Zendcore

configuration Apache, Zend et PHP , Web services
Répondre
Gregory
Messages : 18
Enregistré le : ven. 02 juil. 2010, 13:05:44
Localisation : Midi-Pyrénées

MySql et Zendcore

Message par Gregory »

Bonjour,

Nous avons installé Zendcore pour i5 (version OS400=V6R1), sous le profil QSECOFR, avec succès. Depuis le menu ZENDCORE/ZCMENU, nous pouvons gérer aussi bien le serveur Apache que le daemon MySql.
Mais (il fallait bien un "mais"), lorsque nous redémarrons notre AS400, les sous-systèmes zend et mysql sont bien démarrés, mais le daemon mysql ne démarre pas automatiquement.
Nous avons rajouté une commande (que nous retrouvons sur plusieurs forum http://forums.zend.com/viewtopic.php?f= ... 730#p24730 ) mais l'exécution échoue.
Par ailleurs, normalement lorsque le sous-système ZMYSQL démarre, le daemon démarre automatiquement, ce qui n'est pas le cas pour nous.
Existe-t-il un paramètre dans le fichier de configuration mysql à modifier ? Ou bien existe-t-il une autre commande à exécuter avec QP2SHELL ? A moins que le problème se situe encore ailleurs... ?
Modifié en dernier par Gregory le mer. 18 août 2010, 07:21:00, modifié 1 fois.

cmasse
Site Admin
Messages : 802
Enregistré le : mer. 14 févr. 2007, 18:00:03
Localisation : Nantes
Contact :

Démarrage MYSQL

Message par cmasse »

Bonjour,

s'agit-il du MYSQL livré avec ZendCore (ne contenant pas IBMDB2i) ou d'une version plus récente directement téléchargée sur le site MYSQL ?

pour la version livrée avec ZendCore, voici le CL que j'ai écrit qui appel celui de ZEND

Code : Tout sélectionner

PGM                                                          
  CALL ZMYSQL/ZMYSQLSTRT                                       
ENDPGM               
pour une version standard, il faut lancer un shell

Code : Tout sélectionner

PGM                                                                  
DCL VAR(&CMD) TYPE(*CHAR) LEN(50)                                    
DCL VAR(&PARM) TYPE(*CHAR) LEN(15)                                   
DCL VAR(&NULL) TYPE(*CHAR) LEN(1) VALUE(X'00')                       
                                                                     
                                                                     
  /* LANCEMENT DU DEMON MYSQL   */                                   
             CHGVAR     VAR(&CMD) +                                  
                          VALUE('/Usr/local/mysql/bin/mysqld+        
                          _safe' *TCAT &NULL)                        
             CHGVAR     VAR(&PARM) VALUE('--user=mysql' *TCAT &NULL )
                                                                     
             CALL PGM(QP2SHELL2) PARM(&CMD &PARM)     
ENDPGM       
Christian Massé (Volubis.fr)

Gregory
Messages : 18
Enregistré le : ven. 02 juil. 2010, 13:05:44
Localisation : Midi-Pyrénées

(sans texte)

Message par Gregory »

Tout d'abord merci pour vos réponses et solutions car notre problème est réglé.
Nous avons effectivement le MySQL livré avec Zendcore (téléchargé depuis le site de Zend en début d'année).
L'ajout du premier CL proposé a corrigé notre problème.
Nous avions testé il y a quelques mois le démarrage du daemon MySQL via une commande QP2SHELL mais sans succès (je découvre qu'il existerait une commande QP2SHELL2 ?)
Je vais faire un tour sur le site de MySQL pour plus d'information sur IBMDB2i.
Gregory

cmasse
Site Admin
Messages : 802
Enregistré le : mer. 14 févr. 2007, 18:00:03
Localisation : Nantes
Contact :

IBMDB2i

Message par cmasse »

pour avoir des informations concernant IBMDB2i, je vous conseille la pause-café n° 52 http://www.volubis.fr/Pausecaf/PAUSECAF52.htm

bon courage pour la suite.
Christian Massé (Volubis.fr)

Répondre