Utilisation RPM et erreur 0509-026

IBM i, configuration, commandes, ...
Répondre
OBR
Messages : 10
Enregistré le : mar. 29 avr. 2014, 15:05:25
Localisation : Pfastatt
Contact :

Utilisation RPM et erreur 0509-026

Message par OBR »

Bonjour,

Je viens d'installer RPM sur notre IBMi en V7R2 TR8 avec la procédure trouvée sur le site http://yips.idevcloud.com/wiki/index.ph ... ceBinaries. L'installation se déroule bien jusqu'à l'utilisation de RPM pour installer "wget".

A ce moment là arrive une erreur :
rpm --ignoreos --ignorearch --nodeps --replacepkgs -hUv $rpm_wget
exec() : 0509-036 Impossible de charger le programme rpm en raison des erreurs suivantes :
0509-150 Le module dépendant librpm.so n'a pas pu être chargé.
0509-022 Impossible de charger le module librpm.so.
0509-026 Erreur système: Un fichier ou un répertoire du chemin d'accès n'existe pas.

J'ai pensé à une erreur de PATH, mais il me semble que l'instruction "ln" pour le fichier librpm.so devrait pallier à ce problème.

Avez-vous une idée sur la conduite à tenir pour orienter mes recherches ?

Merci.

cmasse
Site Admin
Messages : 759
Enregistré le : mer. 14 févr. 2007, 18:00:03
Localisation : Nantes
Contact :

5733ops

Message par cmasse »

avez vous 5733OPS ? Quelles options?
Christian Massé (Volubis.fr)

OBR
Messages : 10
Enregistré le : mar. 29 avr. 2014, 15:05:25
Localisation : Pfastatt
Contact :

Message par OBR »

Nous disposons de 5733OPS de l'option *BASE à 15.

cmasse
Site Admin
Messages : 759
Enregistré le : mer. 14 févr. 2007, 18:00:03
Localisation : Nantes
Contact :

wget

Message par cmasse »

Alors je ne comprends pas, vous avez déjà wget dans l'option 7 (tools)

https://www.ibm.com/developerworks/comm ... page/Tools.

désormais IBM conseille d'installer avec YUM https://www.ibm.com/developerworks/comm ... %20RPM%27s
Christian Massé (Volubis.fr)

cmasse
Site Admin
Messages : 759
Enregistré le : mer. 14 févr. 2007, 18:00:03
Localisation : Nantes
Contact :

Re: wget

Message par cmasse »

Alors je ne comprends pas, vous avez déjà wget dans l'option 7 (tools)

https://ibm.co/2sWtcfX

et puis, désormais, IBM conseille d'installer avec YUM https://ibm.co/2I3K26c
Christian Massé (Volubis.fr)

Répondre