RDI - debug infobulle

IBM i, configuration, commandes, ...
Répondre
BrigitteG
Messages : 75
Enregistré le : jeu. 20 sept. 2012, 08:56:38

RDI - debug infobulle

Message par BrigitteG »

Bonjour,

J'utilise RDI pour déboguer des programmes.

Dans le document "S11 - Il n'a jamais été aussi simple de déboguer qu'avec RDp", j'ai lu à la page 38 "Affichage et modification de variables" que nous pouvons voir dans une infobulle la valeur de la zone.
(.ftp://public.dhe.ibm.com/software/fr/ra ... ec_RDp.pdf)

Quand je débogue et que je mets le curseur sur une zone, l'infobulle ne s'affiche pas quand je suis en mode d'affichage *SOURCE. Par contre, elle s'affiche en mode *LISTING.

J'ai regardé dans les préférences, mais je ne vois pas quel paramètre est concerné.

Est-ce possible d'avoir en mode d'affichage *SOURCE l'infobulle sur les variables ?

Je remercie d'avance pour votre aide
Modifié en dernier par BrigitteG le mer. 12 août 2015, 09:59:51, modifié 3 fois.

cmasse
Site Admin
Messages : 757
Enregistré le : mer. 14 févr. 2007, 18:00:03
Localisation : Nantes
Contact :

infobulle

Message par cmasse »

Bonjour,

je suis en DEBUG avec affichage *SOURCE et j'ai les infobulles sans problème.

Quel est votre niveau de version ? 9.1.1.1 ? (Aide/A propos...)
Christian Massé (Volubis.fr)

BrigitteG
Messages : 75
Enregistré le : jeu. 20 sept. 2012, 08:56:38

RDI - debug infobulle

Message par BrigitteG »

Bonjour,
je suis en version 8.5.1.

cmasse
Site Admin
Messages : 757
Enregistré le : mer. 14 févr. 2007, 18:00:03
Localisation : Nantes
Contact :

RDI 9

Message par cmasse »

Cela ne fait pas parti des problèmes corrigés par la version 9
http://www-01.ibm.com/support/docview.w ... wg27038481

voyez si vous pouvez monter vers cette nouvelle version (elle est plus stable) ou bien ouvrez un incident au support IBM.
Christian Massé (Volubis.fr)

BrigitteG
Messages : 75
Enregistré le : jeu. 20 sept. 2012, 08:56:38

RDI - debug infobulle

Message par BrigitteG »

Oui, la version 9 corrige se problème.

Pour info : le problème ne concerne que les pgm en SQLRPGLE.

Sur le pgm en RPGLE, l'infobulle s'affiche bien.

Bonne journée

cmasse
Site Admin
Messages : 757
Enregistré le : mer. 14 févr. 2007, 18:00:03
Localisation : Nantes
Contact :

SE54372

Message par cmasse »

Christian Massé (Volubis.fr)

Goliath62
Messages : 1
Enregistré le : lun. 09 nov. 2015, 12:21:49

Re: RDI - debug infobulle

Message par Goliath62 »

BrigitteG a écrit :Bonjour,

J'utilise RDI pour déboguer des programmes.

Dans le document "S11 - Il n'a jamais été aussi simple de déboguer qu'avec RDp", j'ai lu à la page 38 "Affichage et modification de variables" que nous pouvons voir dans une infobulle la valeur de la zone.
(.ftp://public.dhe.ibm.com/software/fr/ra ... ec_RDp.pdf)

Quand je débogue et que je mets le curseur sur une zone, l'infobulle ne s'affiche pas quand je suis en mode d'affichage *SOURCE. Par contre, elle s'affiche en mode *LISTING.

J'ai regardé dans les préférences, mais je ne vois pas quel paramètre est concerné.

Est-ce possible d'avoir en mode d'affichage *SOURCE l'infobulle sur les variables ?

Je remercie d'avance pour votre aide
j'ai jamais pu résoudre ce genre de problème avec RDI, j'ai la version 8.0

Répondre