open source

RPG (3 et 4, free), CL, SQL, etc...
Répondre
monthi
Messages : 66
Enregistré le : mar. 11 sept. 2018, 15:37:02
Localisation : Paris

open source

Message par monthi »

Bonjour

j'ai vu dans le pause café 84 que l'on pouvait installer PhpPgAdmin pour gérer PostgreSql.

je l'ai mis dans le répertoire où se trouve le fichier conf du serveur postgreSql mais je n'arrive pas l'affiché.
Est ce au bon endroit .
Y a t'il autre chose a faire?

Cdlt

monthi
Messages : 66
Enregistré le : mar. 11 sept. 2018, 15:37:02
Localisation : Paris

Re: open source

Message par monthi »

Bonjour

j'ai trouvé.

J'ai installe le contenu de l'archive dans un répertoire de l'Ifs

J'ai créeun alias au niveau de mon serveur HTTP

Et cela fonctionne.

monthi
Messages : 66
Enregistré le : mar. 11 sept. 2018, 15:37:02
Localisation : Paris

Re: open source

Message par monthi »

Bonjour

peut on démarrer le serveur PostgreSql autrement qu'en interactif avec putty. (pour l'inclure à l'ipl par exemple)

J'ai essayer aves QP2SHELL (ou QP2SHELL2)

Dcl-pr QP2SHELL extpgm;
*n char(65535) const options(*varsize:*nopass);
*n char(65535) const options(*varsize:*nopass);
*n char(65535) const options(*varsize:*nopass);
*n char(65535) const options(*varsize:*nopass);
*n char(65535) const options(*varsize:*nopass);
*n char(65535) const options(*varsize:*nopass);
END-PR;


QP2SHELL('/QOpenSys/pkgs/lib/postgresql12/bin/pg_ctl '+
'-D /postgres'+x'00':
'start'+x'00');

mais il ne démarre rien.

Si j'essaie de la faire dans une session interactive

CALL PGM(QP2SHELL) PARM('/QOpenSys/pkgs/lib/postgresql12/bin/pg_ctl' '-D /postgres' 'start')

j'ai le message suivant pg_ctl : le répertoire « /postgres » n'existe pas

Cdlt

cmasse
Site Admin
Messages : 794
Enregistré le : mer. 14 févr. 2007, 18:00:03
Localisation : Nantes
Contact :

Re: open source

Message par cmasse »

Chez moi QSH CMD('/qopensys/pkgs/bin/pg_ctl start -D /usr/local/pgdata -l logfile') fonctionne

tu as bien fait un pg_ctl -init -D /postgres ?
Christian Massé (Volubis.fr)

monthi
Messages : 66
Enregistré le : mar. 11 sept. 2018, 15:37:02
Localisation : Paris

Re: open source

Message par monthi »

Bonjour Christian

L'init a été fait et je vois bien ma base de donnée postgres via PhpPgAdmin (voir Pj)

j'ai essayer de faire un QSH mais j'ai le message suivant :

FATAL: 58000: strxfrm(), in locale "fr_FR", writes past the specified array
length
ASTUCE : Applique les mises à jour du paquet de bibliothèque système.
EMPLACEMENT : check_strxfrm_bug, pg_locale.c:1097
no data was returned by command ""/QOpenSys/pkgs/lib/postgresql12/bin/postgre
s" -V"
Le programme « postgres » est nécessaire pour pg_ctl, mais n'a pas été t
rouvé
dans le même répertoire que « /QOpenSys/pkgs/lib/postgresql12/bin/pg_ctl Â
».
Vérifiez votre installation.
Press ENTER to end terminal session.

Cdlt
Fichiers joints
phppgadmin.JPG
phppgadmin.JPG (80.31 Kio) Vu 858 fois

Répondre