GET_XML_FILE - XML en version 1.1

RPG (3 et 4, free), CL, SQL, etc...
Répondre
Ced
Messages : 2
Enregistré le : ven. 03 mars 2023, 11:41:33

GET_XML_FILE - XML en version 1.1

Message par Ced »

Bonjour ,

lors de l'utilisation du GET_XML_FILE , j'ai un message d'erreur , SQLSTATE 2200M , SQLCODE -443 en retour si le fichier xml est en version 1.1
aucun problème par contre si le xml est en version 1.0

La seule différence entre les 2 xml est
<?xml version="1.1" encoding="UTF-8"?>
et
<?xml version="1.0" encoding="UTF-8"?>
Ano_XML.JPG
Ano_XML.JPG (50.33 Kio) Vu 2386 fois


Une idée sur l'origine du problème ?
Merci

nbonnet
Messages : 200
Enregistré le : mar. 11 sept. 2018, 08:20:13
Localisation : Lyon

Re: GET_XML_FILE - XML en version 1.1

Message par nbonnet »

Bonjour,

effectivement, DB2 ne prend en charge que version 1.0.

La doc https://www.ibm.com/docs/en/i/7.4?topic ... mlvalidate indique :
DOCUMENT
Specifies that the XML value resulting from XML-expression must be a well-formed XML document that conforms to XML Version 1.0.
Je n'ai pas trouvé d'option ou de réglage, même par SET CURRENT IMPLICIT XMLPARSE OPTION(cf https://www.ibm.com/docs/en/i/7.4?topic ... rse-option).

Solutions : supprimer le prologue xml !
Sinon ouvrez une demande auprès d'IBM
Nathanaël

Ced
Messages : 2
Enregistré le : ven. 03 mars 2023, 11:41:33

Re: GET_XML_FILE - XML en version 1.1

Message par Ced »

Merci pour ton retour Nathanaël

PaulM
Messages : 1
Enregistré le : mer. 02 août 2023, 05:26:38

Re: GET_XML_FILE - XML en version 1.1

Message par PaulM »

Bonjour,

Effectivement, d'après la documentation IBM, la version 1.0 est la seule prise en charge par DB2 pour le moment. Vous pourriez envisager de supprimer le prologue XML comme solution temporaire.

Répondre