12 résultats trouvés

par raphael1980
lun. 26 avr. 2021, 14:15:08
Forum : langages
Sujet : RESPONSEMSG qui contient un - lors d'une 400
Réponses : 16
Vues : 856

Re: RESPONSEMSG qui contient un - lors d'une 400

Complètement d’information, si on ne fait pas en verbose, qu’on dit à l’handler de continuer, on sait faire plusieurs centaines d’attaques en update sur l’API sans augmenter l’espace disque… Le soucis, c’est qu’on avait besoin d’une réponse exploitable de l’API pour savoir quand faire un POST ou un ...
par raphael1980
lun. 26 avr. 2021, 12:09:28
Forum : langages
Sujet : RESPONSEMSG qui contient un - lors d'une 400
Réponses : 16
Vues : 856

Re: RESPONSEMSG qui contient un - lors d'une 400

C'est un comportement normal d'avoir une erreur java quand on a un 400 ?

Sans le verbose
SansVerbose.PNG
SansVerbose.PNG (41.99 Kio) Vu 80 fois
Avec le verbose
AvecVerbose.PNG
AvecVerbose.PNG (28.43 Kio) Vu 80 fois
Au final en arrière plan, il y a sans doute l'erreur java qui fait grossir les logs.
par raphael1980
lun. 26 avr. 2021, 09:41:18
Forum : langages
Sujet : RESPONSEMSG qui contient un - lors d'une 400
Réponses : 16
Vues : 856

Re: RESPONSEMSG qui contient un - lors d'une 400

je pense que c'est effectivement les messages d'erreur java. Si on le fait sans le verbose et on a ce genre de message : CRM/TRTCLITMPTEST sur le serveur XXX Erreur = Java stored procedure or user-defined function SYSTOOLS.HTTPGETCLOB, specific name HTTPG00005 aborted with an exception "java.io.File...
par raphael1980
lun. 26 avr. 2021, 07:25:03
Forum : langages
Sujet : RESPONSEMSG qui contient un - lors d'une 400
Réponses : 16
Vues : 856

Re: RESPONSEMSG qui contient un - lors d'une 400

C’est peut-être une piste. Si on n’active pas le verbose, on reçoit effectivement un message java quand les api retournent autre chose qu’un joli 200. On est passé en verbose et includeErrorMsg pour traiter les réponses qui ne sont pas des 200 et éviter d’avoir un message java qui arrête le traiteme...
par raphael1980
sam. 24 avr. 2021, 08:36:25
Forum : langages
Sujet : RESPONSEMSG qui contient un - lors d'une 400
Réponses : 16
Vues : 856

Re: RESPONSEMSG qui contient un - lors d'une 400

Lundi, on fera une révision de la PS. Peut-être qu'un point m'échappe qui génère une erreur dans le post traitement API. Ici je l'ai fait tourner, +- 400 appels à l'API, j'ai grillé 2% d'utilisation du disque qui sera nettoyé cette nuit par le système. Est-ce que tu crois que cela peut venir du fait...
par raphael1980
ven. 23 avr. 2021, 08:43:00
Forum : langages
Sujet : RESPONSEMSG qui contient un - lors d'une 400
Réponses : 16
Vues : 856

Re: RESPONSEMSG qui contient un - lors d'une 400

Hello, À votre avis, la fonction HTTPPOSTCLOBVERBOSE pourrait être responsable d’un nombre de diagnostics trop élevé ? Erreur = The maximum number of stacked diagnostics areas has been exceeded. Et d’un gonflement temporaire d’espace disque que le système libère par la suite ? On fait par moment plu...
par raphael1980
jeu. 08 avr. 2021, 12:13:51
Forum : langages
Sujet : RESPONSEMSG qui contient un - lors d'une 400
Réponses : 16
Vues : 856

Re: RESPONSEMSG qui contient un - lors d'une 400

Bon, j'ai triché.... :twisted:

J'ai envoyé un post et j'ai redéfini la méthode dans l'URL.

url + "?_HttpMethod=PATCH"

Du bricolage mais je ne voyais pas comment faire autrement.
par raphael1980
jeu. 08 avr. 2021, 11:10:12
Forum : langages
Sujet : RESPONSEMSG qui contient un - lors d'une 400
Réponses : 16
Vues : 856

Re: RESPONSEMSG qui contient un - lors d'une 400

J’ai malgré tout un autre souci.

On souhaite utiliser l’API de SalesForce qui n’accepte pas les méthodes PUT mais juste des PATCH.

Hors, je ne vois pas de fonction qui permet de faire un HTTPPATCH.

Une idée ? Une piste ?
par raphael1980
mar. 06 avr. 2021, 08:09:56
Forum : langages
Sujet : RESPONSEMSG qui contient un - lors d'une 400
Réponses : 16
Vues : 856

Re: RESPONSEMSG qui contient un - lors d'une 400

je ne t'avais pas compris !

C'est ok , je devais simplement mettre includeErrorMsg="true" dans le httpHeader !

Merci pour ton aide.
par raphael1980
mar. 06 avr. 2021, 08:06:00
Forum : langages
Sujet : RESPONSEMSG qui contient un - lors d'une 400
Réponses : 16
Vues : 856

Re: RESPONSEMSG qui contient un - lors d'une 400

Effectivement, j'avais espérer l'avoir dans RESPONSEMSG mais j'ai un joli - Le header aide un peu mais ne donne pas non plus l'erreur exact retournée dans le JSON en body de l'API. <?xml version="1.0" encoding="UTF-8" ?> <httpHeader responseCode="400"> <responseMessage>Bad Request</responseMessage> ...
par raphael1980
mar. 06 avr. 2021, 07:14:24
Forum : langages
Sujet : RESPONSEMSG qui contient un - lors d'une 400
Réponses : 16
Vues : 856

Re: RESPONSEMSG qui contient un - lors d'une 400

J’aurais du le préciser. J’ai évidement testé via postman. L’API répond bien un message de retour du genre. [ { "message": "RC: bad value for restricted picklist field: 35", "errorCode": "INVALID_OR_NULL_FOR_RESTRICTED_PICKLIST", "fields": [ "FW_Commerciale__c" ] } ]
par raphael1980
ven. 02 avr. 2021, 12:10:34
Forum : langages
Sujet : RESPONSEMSG qui contient un - lors d'une 400
Réponses : 16
Vues : 856

RESPONSEMSG qui contient un - lors d'une 400

Hello, J’essaie d’utiliser le HTTPPOSTCLOBVERBOSE de SYSTOOLS mais je ne reçois pas le body d’API attaquée quand le code retour est 400 ou 500 mais un simple -. Aucun problème quand le code retour est 200. select * FROM TABLE (systools.httpPostClobVERBOSE ( CAST ( 'URL' as varchar(200) CCSID 1208), ...