14 résultats trouvés

par jysaulieres
ven. 14 févr. 2020, 13:21:26
Forum : Système
Sujet : Probleme de droit dans l'IFS
Réponses : 0
Vues : 18

Probleme de droit dans l'IFS

Bonjour, Nous sommes en V7R3 TR6 (SF99730 niveau 19116) Voici ce que je compte faire : un profil P1 génère un fichier dans un dossier de l'IFS. Un profil P2 doit transmettre ce fichier en SFTP. Les 2 profils n'ont aucun droits particuliers (classe=*USER, droits spéciaux=*NONE, ils n'appartiennent pa...
par jysaulieres
jeu. 05 sept. 2019, 15:31:25
Forum : Web
Sujet : Web service et HTTPS
Réponses : 9
Vues : 3003

(sans sujet)

Vous m'avez mis sur la piste : c'etait bien le "common name" du certificat créé automatiquement qui ne fonctionnait pas. En créant le certificat manuellement et en l'affectant au CA, puis, attribuer ce certificat à l'application, puis en intégrant le CA dans java, c'est passé. Merci beaucoup pour vo...
par jysaulieres
mer. 21 août 2019, 11:45:58
Forum : Web
Sujet : Web service et HTTPS
Réponses : 9
Vues : 3003

(sans sujet)

En suivant la doc : - configuration SSL sur le serveur apache (nom : WSMAJ01) - etape 4 de la config SSL, coche de "issue new certificat by CA" => création automatique d'un nouveau CA qui a pour nom certificate : LOCAL_CERTIFICATE_AUTHORITY_ x(7) common name : tests_CERTIFICATE_AUTHORITY (notre LPAR...
par jysaulieres
mar. 20 août 2019, 16:36:57
Forum : Web
Sujet : Web service et HTTPS
Réponses : 9
Vues : 3003

(sans sujet)

C'est bien pour ça que notre webservice ne sera appelé que sur notre LAN. A partir un IBM i (une partition) ou d'un serveur linux. Le but étant juste de crypter l'échange entre nos systèmes. Pour vous, cela ne peut pas être mis en place ? Impossible d'appeler un WS en https via une requète SQL (HTTP...
par jysaulieres
mar. 20 août 2019, 08:46:20
Forum : Web
Sujet : Web service et HTTPS
Réponses : 9
Vues : 3003

(sans sujet)

Ca fonctionne avec RestClient sur Firefox après avoir ajouté l'adresse IP en exception : "10.x.x.x:10234 uses an invalid security certificate. The certificate is not valid for the name 10.x.x.x. Error code: SSL_ERROR_BAD_CERT_DOMAIN". Idem avec POSTMAN ça fonctionne en désactivant la vérification du...
par jysaulieres
lun. 19 août 2019, 16:10:44
Forum : Web
Sujet : Web service et HTTPS
Réponses : 9
Vues : 3003

(sans sujet)

Bonjour, J'ai mis en place un webservice de test (sur le LAN) sur un IBMi V7R3 (niveau de cum 18242) et configuré également le HTTPS sur un autre port. Quand j'interroge le webservice en http/https via Firefox/RestClient il me répond bien. Sur mon IBM i : - Le WS répond sur le port non sécurisé (via...
par jysaulieres
mer. 29 mai 2019, 07:37:21
Forum : Client Access
Sujet : TELNETS
Réponses : 3
Vues : 2204

(sans sujet)

Bonjour, j'ai trouvé une doc qui demandai d'attribuer un certificat pour le serveur TELNET mais aussi pour SIGNON et CENTRAL SERVER (ce que je n'ai pas fait). Sauf qu'entre temps j'ai supprimé des certificats et je ne peux plus rien faire. Je dois remonter mon système, mais pb lors de l'ipl D , le s...
par jysaulieres
ven. 24 mai 2019, 15:59:18
Forum : Client Access
Sujet : TELNETS
Réponses : 3
Vues : 2204

(sans sujet)

Bonjour, J'ai créé un certificat sur mon système en suivant la doc IBM - création d'un CA STORE - création certificat pour TELNET Puis CHGTELNA ALWSSL(*YES) En lançant une émulation via ACS, si je sélectionne TELNET SECURISE (config de l'émulation = Telnet TLS/SSL port 992) ca fonctionne seulement s...
par jysaulieres
lun. 12 nov. 2018, 10:16:11
Forum : Web
Sujet : Web Service RPGLE Probleme CCSID
Réponses : 14
Vues : 6988

(sujet inconnu)

Bonjour,

En modifiant le fichier httpd.conf ça fonctionne correctement, tous les caractères accentués (et autres cédilles ...) fonctionnent en retour.

merci encore pour votre temps et votre analyse.
par jysaulieres
mer. 31 oct. 2018, 12:53:28
Forum : Web
Sujet : Web Service RPGLE Probleme CCSID
Réponses : 14
Vues : 6988

Quand je fais un : SELECT cast(substr(RESPO00002, 1, 1500) as varchar(1500)) FROM table(SYSTOOLS.HTTPGETCLOBverbose( 'http://MonAS:10032/web/services/WS1208/abc', '')) as Reponse j'obtiens : <?xml version="1.0" encoding="UTF-8" ?><httpHeader responseCode="200"><responseMessage>OK .... <header name="...
par jysaulieres
mer. 31 oct. 2018, 08:30:02
Forum : Web
Sujet : Web Service RPGLE Probleme CCSID
Réponses : 14
Vues : 6988

Merci encore pour votre analyse et pour l'ouverture du ticket au point service. Je vais suivre avec intérêt la suite donnée par IBM.
par jysaulieres
mar. 30 oct. 2018, 10:35:39
Forum : Web
Sujet : Web Service RPGLE Probleme CCSID
Réponses : 14
Vues : 6988

Bonjour, Quand on exporte les données via le DBCLOB_FILE, on dirait qu'il y a un double encodage ... je m'explique : 1) le caractère "é" est normalement codé en UTF8 sur 2 octets qui ont pour valeur héxa 0xC3 0xA9 et représentés par les codes EBCDIC 297 par "é". 2) les caractères "é" sont respecti...
par jysaulieres
lun. 29 oct. 2018, 14:16:08
Forum : Web
Sujet : Web Service RPGLE Probleme CCSID
Réponses : 14
Vues : 6988

Bonjour, Oui, les caractères accentués sont bien affichés quand je lance cette requête sur le site public. => ...."Collège Anne de Bretagne"} , "_l" : [ 47.2065481346042..... Voila mon source WS en RPG (très simplifié pour ne tenir compte que des accents) : Ctl-opt alwnull(*usrctl) pgminfo(*pcml:*mo...
par jysaulieres
ven. 26 oct. 2018, 12:39:11
Forum : Web
Sujet : Web Service RPGLE Probleme CCSID
Réponses : 14
Vues : 6988

Web Service RPGLE Probleme CCSID

Bonjour, Nous avons 2 partitions IBM i (V7R2 TR8 SF99720 niveau 18032) Installés : 5770SS1 option 39, JV1 opt 11,14 à 17 variable environnement JAVA_HOME = .../JavaVM/jdk80/32bit Mon soucis : J'ai mis en place un web service REST en RPPGLEsur une partition "A" qui me renvoie des caractères accentués...